Update issue

Incident Report for Procoder StatusPage

Identified

We are having some issues where the terminal is not saving some updates, so a few of the site updates may be late or not existent at all. We are working hard to fix this issue.
Posted Nov 28, 2020 - 15:11 UTC